Features

Errors/Failures during Testing

Below is a list of various error messages and failures that might happen when running Automated Tests.

Minutes depleted

Description:

The test failed because your account does not have enough minutes left. If your account does not have enough minutes, tests can no longer be started on TestingBot.

How to resolve:

Please consider upgrading your account to make sure you have enough credits/minutes to run tests.

Your test exceeded max duration

Description:

The test was terminated because it exceeded the maximum duration allowed. (default is 1800 seconds)

Cause:

This might be caused by several things:

  • Your test is too long. Consider splitting a large tests into multiple smaller tests.
  • Tests running on TestingBot can take longer to run than they do locally
  • Your test is stuck in an endless loop, where your test keeps sending commands

How to resolve:

  • Consider breaking up your test into smaller, atomic tests.
  • You can use the maxDuration desired capability option to indicate to TestingBot how long you want TestingBot to wait for your test to complete.
  • Check for endless loops in your test

Your test timed out

Description:

This error happens when TestingBot does not receive any new command from your Selenium script for more than 90 seconds (the default timeout duration).

Cause:

This might be caused by various things:

  • You forgot to add driver.quit() or browser.stop at the end of your test. To prevent your test from running forever, TestingBot will stop the test after 90 seconds to prevent this test from consuming all your minutes.
  • Your test script crashed, was interrupted or lost internet connectivity.
  • Maybe your test command needs more than 90 seconds between commands. In this case, you can specify a different test idle timeout.

How to resolve:

  • Make sure your test script has good internet connectivity.
  • Don't forget to add driver.quit or browser.stop at the end of your test.
  • Specify a different test idle timeout.

New session cancelled before test start

Description:

Your test runner started a new test on TestingBot, but then closed the connection to TestingBot before TestingBot could make a new test session available.

Cause:

This might be caused by several things:

  • Client timeout with Android/iOS tests. Please make sure to set the connection timeout in your test runner/framework high enough, as iOS/Android simulators take a while to start up. We recommend at least 2 minutes.
  • You might be running too many tests at once. If you're exceeding the total number of simultaneous tests, we still queue the tests. If this queueing takes too long, your test runner might disconnect before the test started.
  • High waiting times at TestingBot. If our service has any issues, this error might occur. Follow us on Twitter (@testingbotops) and check our Status Page: https://status.testingbot.com

How to resolve:

  • Increase the connection timeout setting in your test runner/framework.
    For example, for WebdriverIO, you can set connectionRetryTimeout: 210000
  • Make sure you're not exceeding the total allowed simultaneous tests, according to the TestingBot plan you're subscribed to.